Degraded Performance in Live Chat Support and Text Messaging

Incident Report for Golf Genius TM

Resolved

Amazon Web Service has now corrected all issues. As a result, our Text Messaging and Chat Support partners are fully operational as well.
Posted Oct 20, 2025 - 23:00 EDT

Monitoring

We are experiencing degraded service due to an ongoing issue with Amazon Web Services (AWS).

The product remains functional, but certain services and features are affected. The impacted features include:
- Help Button Live Chat (Intercom)
- Some Text Message Delivery (primarily outside the US)

While the interruption to these services is caused by an ongoing issue with AWS, we are actively working to minimize the impact.
Posted Oct 20, 2025 - 09:09 EDT
This incident affected: Live Chat Support and System (Text Messaging).